CentOS7.8安装docker CE

Docker简介

百科说:Docker 是一个开源的应用容器引擎,让开发者可以打包他们的应用以及依赖包到一个可移植的容器中,然后发布到任何流行的Linux机器上,也可以实现虚拟化,容器是完全使用沙箱机制,相互之间不会有任何接口。

看起来有点雾,用过虚拟机的应该对虚拟化技术有点印象,不知道也没关系,就把它当成轻量级的虚拟机吧(虽然一个是完全虚拟化,一个是操作系统层虚拟化),这个解释到位:

百科又说:Docker 使用客户端-服务器 (C/S) 架构模式 使用远程API来管理和创建Docker容器。Docker 容器(Container)通过 Docker 镜像(Image)来创建,二者之间的关系类似于面向对象编程中的对象与类

那Docker由什么组成呢, 包括三个基本概念:

仓库(Repository)

镜像(Image)

容器(Container)

打个比方:你如果想玩英雄联盟中骚气的亚索,你首先得有这个英雄(Docker的镜像),然后你得花金币去英雄商店(Docker的仓库)买,接着进游戏就会看到一个半蹲的发型飘逸的剑客(Docker的容器),所以:

  1. 其中Registry是Docker用于存放镜像文件的仓库,Docker 仓库的概念跟Git 类似(就像商店存放所有的英雄,只是更改英雄的权限在某些非程序员手里)。

  2. 所谓镜像就是构建容器的源代码,是一个只读的模板,由一层一层的文件系统组成的,类似于虚拟机的镜像(英雄也是只读的,有自己的技能被动,你也不能进行操作)。

  3. 那么容器就是由Docker镜像创建的运行实例,类似于虚拟机,容器之间是相互隔离的,包含特定的应用及其所需的依赖文件(好比每个英雄都是隔离的,都有自己的皮肤,技能以及走的路线)。

注:Docker Hub是Docker公司提供的一个注册服务器(Register)来保存多个仓库,每个仓库又可以包含多个具备不同tag的镜像

Docker安装

我是虚拟机装的Centos7.8,linux 3.10 内核,docker官方说至少3.8以上,建议3.10以上(ubuntu下要linux内核3.8以上, RHEL/Centos 的内核修补过, centos6.5的版本就可以——这个可以试试)

一、Centos版本为7.8

2.jpg

二、内核版本为3.10

1.jpg

三、root账户登录,查看内核版本如下

输入uname -r

1
2
[root@iZ2vc2em3ma84cj1zfcwqfZ ~]# uname -r
3.10.0-1127.13.1.el7.x86_64

3.jpg
或者uname -a

1
2
[root@iZ2vc2em3ma84cj1zfcwqfZ ~]# uname -a
Linux iZ2vc2em3ma84cj1zfcwqfZ 3.10.0-1127.13.1.el7.x86_64 #1 SMP Tue Jun 23 15:46:38 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux

4.jpg

四、把yum包更新到最新

1
[root@iZ2vc2em3ma84cj1zfcwqfZ ~]# yum update

21.jpg
22.jpg

23.jpg

24.jpg

五、安装需要的软件包, yum-util

提供yum-config-manager功能,另外两个是devicemapper驱动依赖的(或者执行这个命令)

1
[root@iZ2vc2em3ma84cj1zfcwqfZ ~]# yum install -y yum-utils device-mapper-persistent-data lvm2

25.jpg

26.jpg

六、设置yum源

1
2
3
4
5
6
[root@iZ2vc2em3ma84cj1zfcwqfZ ~]# yum-config-manager --add-repo https://download.docker.com/linux/centos/docker-ce.repo
Loaded plugins: fastestmirror
adding repo from: https://download.docker.com/linux/centos/docker-ce.repo
grabbing file https://download.docker.com/linux/centos/docker-ce.repo to /etc/yum.repos.d/docker-ce.repo
repo saved to /etc/yum.repos.d/docker-ce.repo
[root@iZ2vc2em3ma84cj1zfcwqfZ ~]#

七、可以查看所有仓库中所有docker版本,并选择特定版本安装

1
[root@iZ2vc2em3ma84cj1zfcwqfZ ~]# yum list docker-ce --showduplicates | sort -r

27.jpg

八、安装Docker,命令:yum install docker-ce-版本号,我选的是17.12.1.ce,如下

1
2
3
4
5
6
7
8
9
10
11
12
13
14
# yum install docker-ce-17.12.1.ce
已加载插件:fastestmirror, langpacks
Loading mirror speeds from cached hostfile
* base: centos.ustc.edu.cn
* extras: mirrors.aliyun.com
* updates: centos.ustc.edu.cn
base | 3.6 kB 00:00
docker-ce-stable | 2.9 kB 00:00
extras | 3.4 kB 00:00
updates | 3.4 kB 00:00
正在解决依赖关系
--> 正在检查事务
---> 软件包 docker-ce.x86_64.0.17.12.1.ce-1.el7.centos 将被 安装
--> 正在处理依赖关系 container-selinux >= 2.9,它被软件包 docker-ce-17.12.1.ce-1.el7.centos.x86_64 需要

九、启动Docker,命令:systemctl start docker,然后加入开机启动,如下

1
2
3
[root@iZ2vc2em3ma84cj1zfcwqfZ ~]# systemctl start docker
[root@iZ2vc2em3ma84cj1zfcwqfZ ~]# systemctl enable docker
Created symlink from /etc/systemd/system/multi-user.target.wants/docker.service to /usr/lib/systemd/system/docker.service.

十、验证安装是否成功(有client和service两部分表示docker安装启动都成功了)

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
[root@iZ2vc2em3ma84cj1zfcwqfZ ~]# docker version 
Client:
Version: 17.12.1-ce
API version: 1.35
Go version: go1.9.4
Git commit: 7390fc6
Built: Tue Feb 27 22:15:20 2018
OS/Arch: linux/amd64

Server:
Engine:
Version: 17.12.1-ce
API version: 1.35 (minimum version 1.12)
Go version: go1.9.4
Git commit: 7390fc6
Built: Tue Feb 27 22:17:54 2018
OS/Arch: linux/amd64
Experimental: false