解决composer遇到No valid bower.json was found in any branch or tag

最近在阿里云上研究VPC,毕竟原来的经典网络不够安全,于是买了一个,往上面部署个项目,

composer啊、中国镜像啊,都弄好了。

坑爹的事情来了,我执行 composer install --prefer-dist的时候,提示了个

[Composer\Repository\InvalidRepositoryException]
No valid bower.json was found in any branch or tag of https://github.com/bestiejs/punycode.js.git, could not load a package from it.
`</pre>

整整一下午没有找到解决方案,后来发现一台新的服务怎么composer没有提示我输入GitHub的授权token呢。
原来我手残了,上次提交代码的时候把composer.lock提交了上去,知道我只能尝试着设置token。最后找了方式。
在composer.json里面 写入一下代码

<pre class="line-numbers prism-highlight" data-start="1">`"config": {
    "process-timeout": 1800,
    "github-oauth": {
        "github.com": "你的授权token"
    }
}

之后执行composer install --prefer-dist成功了。